Heute habe ich auf sehr elegante Art und Weise eine Seite abgeschossen. Ich habe zwei Seiten zu einem ähnlichen Thema, jede dieser Seiten fängt mit dem gleichen Keyword an. Also zum Beispiel arbeiten-keyword1 und arbeiten-keyword2. Die eine Domain läuft mit WordPress, die andere nicht. Das CMS von Domain zwei ist selbst programmiert und läuft nicht unter PHP 7 (SQL-Anfragen noch nicht angepasst).

Domain eins wollte ich heute auf SSL umstellen, da ich sonst die Kommentare deaktivieren müsste (muss ich hier noch tun, auf SSL umstellen). Ich gehe also ins Panel, klicke auf Domain, sehe dann, dass PHP als CGI und nicht als Modul läuft, wundere mich kurz, da ich vorher ja die FTP Zugangsdaten eingeben musste um WordPress abzudaten, denke mir aber nix weiter und überlege, naja, wenn das eh auf CGI steht, dann kann ich statt 5.6 auch 7.0 nehmen, ist ja schneller. Stelle um. Aktiviere SSL und gehe bei WordPress auch hin und ändere unter Optionen die Domain. Alles speichern, fünf MInuten warten, wundern. Ok, vielleicht noch nicht durch, SSL kann ja etwas dauern. Arbeite ich also an der anderen Seite weiter, da muss noch ein Artikel hochgestellt werden.

Dort läuft gar nix mehr.  Nur Fehlermeldungen. Ja, ich hatte aus versehen diese Seite umgstellt. Von den Verlinkungen wäre das ja nicht schlimm gewesen, auch der Wechsel von mit www auf ohne www in der Url-Struktur stört da eigentlich nicht. Aber PHP 7 mochte die seite so gar nicht. Stossgebet, überlegt wann ich die letzte Sicherung gemacht habe (zum Glück nur drei Stunden her) und alles wieder auf Anfang gesetzt.

Das ging zum Glück. Einen riesigen Schreck habe ich trotzdem bekommen.